Smarthphone aufladen von anderen Geräten verhindern

    Smarthphone aufladen von anderen Geräten verhindern

    Hey,

    ich habe gerade ein Projekt bei dem ich zwei Verbraucher mit einer Stromquelle versorgen möchte:
    1. Smartphone/Tablet (aufladen)
    2. LED Leiste (leuchten)
    Ich habe das ganze wie folgt aufgebaut:
    usb power problem.png

    Wie man sieht besteht das ganze aus 3 Teilen:
    1. Smartphone
    2. LED Leiste
    3. Ladegerät
    Das funktioniert so auch gut, wenn ich das Ladegerät anschließe und danach das Smartphone . Wenn allerdings das Smartphone zuerst angeschlossen wird (vor dem Ladegerät), dann versogt das Handy die LED-Leiste mit Strom. Selbst wenn ich nun nachträglich das Ladegerät noch dazufüge, lädt das Smartphone nicht auf.

    Ich möchte vermeiden, dass das Smartphone die Schaltung mit Strom versorgt. Es soll nur laden, sollte das Ladegerät angeschlossen sein, andernfalls sich quasi vom Stromkreis trennen.

    Hat da jemand eine Idee?

    Vielen Dank
    Death

    fyi: Damit das Smartphone lädt, habe ich die Datenleitungen des USB-Ports kurzgeschlossen (Tutorial empfiehlt einen 100Ohm widerstand, aber mit dem hat mein altes Tablet nicht geladen).

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Daeth“ ()

    gigagames schrieb:

    Ich würde einfach eine diode zwischen USB +5v und denn Handy +5v setzen

    Müsst ich mal probieren, aber habe bedenken wegen dem Spannungsabfall von ~0,7V an der Diode.

    Edit: Es scheint zu funktionieren, solange die Spannung des Tablets kleiner als die des Ladegerätes ist. Mein voll aufgeladenes Handy lädt nicht, mein leeres Tablet lädt. Das könnte mir so reichen. Ich meld mich wieder :)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Daeth“ ()

    Es hat erst angezeigt das es lädt, aber jetzt zeigt es gar nichts mehr an. Wenn ich das Kabel anstecke (mit oder ohne strom) wird es auch als OTG erkannt. Wenn ich normales ladekabel ansteck wird dieses nicht als OTG erkannt (aber lädt). Hat da jemand Erfahrung, wie ich die Datenleitungen 'schalten' muss, damit es als ladegerät funktioniert? Oder weiß jemand, wieso es nur manchmal lädt?
    Das nervt mich jetzt schon länger, da es eigentlich laut der Anleitung funktionieren muss, wenn ich nen 100Ohm widerstand an die Datenleitungen pack, bzw kurzschließe.